Page 1 of 1

Reversing DoubleSpace compression

PostPosted: Mon May 04, 2020 7:12 pm
by mentalfloss
I wanted to undo the level of compression that I had DoubleSpace make on my system drive, but am having trouble figuring out how to do so.

Ultimately I wanted to reduce the compression level, but when it rebooted to apply it seemed it was re-applying the same compression level. (I didn't verify this afterwards, though) So I'm trying to start from scratch by reversing the compression, then re-apply it with the compression level I want.

But I can't figure out how to reverse the compression I applied and decompress the drive using DoubleSpace. What method should I use?

Additionally, is there an online manual/helpfile/wiki for DoubleSpace? (and DriveSpace?)

Re: Reversing DoubleSpace compression

PostPosted: Wed May 06, 2020 7:48 am
by admin
Hey, great question!

Short Answer: You can change the compression method of your disk by using an Undo Disk. The moment you check the Undo Disk box, the compression slider will be enabled, and you will also have the option to Uncompress your disk.

Long Answer: Changing your compression method actually requires a full recompression pass, unlike just updating your disk with the same compression you had used earlier (which just deletes stale data and adds new data to your existing compressed disk image - saving gobs of processing time on data that remains unchanged, as well as eliminating the need for temporary storage to hold a brand new disk image file).

For that full recompression pass, you may use an external disk with enough space to hold your disk image file (keep in mind it will be larger than what you have now, since you're planning to reduce your compression grade), or it can be an internal disk/partition with enough room.

There is no need to uncompress your disk first, as that would essentially add an extra step which would just slow things down. In fact, when uncompressing your disk, you will essentially be doing a recompression pass, and then applying your disk image in uncompressed form from your Undo Disk to your target disk.

Does that help?

For online help, you can install the full desktop version of ZIPmagic from

Re: Reversing DoubleSpace compression

PostPosted: Wed May 06, 2020 11:36 pm
by mentalfloss
Sort of, but the term "Undo" doesn't appear anywhere on the interface, in the "Recompress" button's drop-down menu or the Options screen within that. This is for the version purchased from the Microsoft Store, although:

I own ZIPmagic as well however the Microsoft Store edition of DoubleSpace is the one I've installed on this particular machine and was surprised it was without any help system or manual. While it works well, it's hard to know what magic is zipping, options are doing and methods need following. So here I am.

On another computer I installed the ZIPmagic suite I purchased, and the Start menu's "ZIPMagic 19" folder has DoubleSpace 3 as well, however the ZIPmagic Help doesn't contain the word DoubleSpace and I'm confused where else to look.

Re: Reversing DoubleSpace compression

PostPosted: Fri May 08, 2020 12:26 am
by admin
Sorry, it used to be called "Undo Disk" in earlier versions; now its called "Backup Disk", which more accurately describes its usage.

The disk compression documentation is covered in the help file/Start Menu help link titled "LZS Disk Compression Help".

I think its a great suggestion to have this help included in our Microsoft Store releases as well - thank you!

Re: Reversing DoubleSpace compression

PostPosted: Sat May 09, 2020 12:02 am
by mentalfloss
Ah okay cool, I'm in the process of decompressing the disk and have hit a snag.

I tried to reduce the compression level, but it reset it back to Maximum (notified by the voice sample played, saw the slider position after) just before it popped up a dialogue box asking for confirmation. (I think, didn't note the steps) So I went with the Uncompress option within the button's menu and using a USB drive as my Backup Disk.

It's at a point where it's been processing for over 8 hours and shows:
File: Saving excluded folder 5 of 6
Time Remaining: D:\mnt

The mnt folder contains NTFS mount points for storage volumes/media, and the only thing in it is the mount point for the internal microsd card.

The program still seems to be active as there's animation going along the portion that usually shows the throughput.

I opened a command prompt and looked at the ZIPmagic.wim.log.txt files in C: (which also has a ~9gig ZIPmagic.wim file) and D: and these are the last lines in each:

C: - save WIM into C:\ZIPmagic.wim:: 0 [WIMLIB] (at 2472828)
D: - extract WIM to C:\:: 0 [WIMLIB) (at 3106328)

Also in D:\mnt (which looks like it's formerly my C:\ drive) and list the directory it shows:

04/25/2020 10:27 AM <JUNCTION> sdcard [\??\Volume{d77c8174-8714-11ea-9e62-00215cd61dd3}\]

But when I try and cd into sdcard I get "The system cannot find the path specified." although the SD card is still in the device. (an Intel HDMI Stick)

Not quite sure if I should leave it be or interrupt it at this point. Should I delete the sdcard junction in the command prompt?

Re: Reversing DoubleSpace compression

PostPosted: Sat May 09, 2020 4:57 am
by admin
It seems to me that the process never got through the backup of your excluded folders, so would probably be safe to interrupt.

I must admit I don't fully understand the details of your setup have a folder with various mount points, some of which are active, and others aren't? Some drives can be read from but some cannot - why would this be, do you have a hardware error?

To help me assist you more, I would suggest you reach out to me directly by email with more information on your case. I would essentially attempt to replicate your setup here and see if there's an issue I can reproduce with the software, or that failing, maybe get some ideas on what you might check for.

Since you also already have your zipmagic.wim file - assuming you're OK reverting to the state your PC was in when you last compressed your disk with DoubleSpace - it might be simplest for you to copy that file to an external disk, and just do a restore from there, in uncompressed mode.

I wish I could help you more with what limited I know...

Re: Reversing DoubleSpace compression

PostPosted: Sat May 09, 2020 6:27 pm
by mentalfloss
(just posting this here so others can get the info in the future, but I'll email you shortly afterwards unless you want to continue this here)

Some year ago I started to use folders inside \mnt to mount NTFS partitions on hard disks. You can do this in Windows's Disk Management when right-clicking on a partition and selecting "Change drive letters and paths". For computers with 8 drives in a JBOD I don't need to have 8+ drive letters taken up, and with the computer I'm debugging the sdcard I did a folder mount to \mnt\sdcard. One partition can have a bunch of NTFS folder mounts in different places in addition to its drive letter.

Something to note about the behaviour of NTFS folder mounts that might play role here: I create one by making an empty folder inside \mnt and then mapped the partition to that folder -- in my case \mnt\sdcard. When you CD into \mnt and list its content, it now shows the folder you mapped as a "JUNCTION" instead of a "DIR". But, if the partition is absent when the computer boots (and maybe if the disk drops after boot), then that folder remains just a regular folder like any other and when you list the folder it shows as "DIR" and not "JUNCTION". So it's interesting that it's still listed as JUNCTION, like the partition was present and active when it booted, but I can't CD into it and it seems like where the process is stuck.

Re: Reversing DoubleSpace compression

PostPosted: Sat May 09, 2020 10:38 pm
by admin
Oh sounds like that's the problem, then. If apps cannot change into that directory...that could certainly stall/break things.

I guess with that detailed description, there's really no need for a private follow up - thank you!

Obviously the solution would be temporarily removing that inaccessible junction, and reattempting the operation.

DoubleSpace obviously is only as good as the underlying operating system is...

Have you tried that already?

Re: Reversing DoubleSpace compression

PostPosted: Sat May 09, 2020 11:58 pm
by mentalfloss
There should be no need to remove it -- it works.

The installed Windows 10 on the machine hasn't had an issue with the junction/NTFS folder mount and it's been live for quite a while through many reboots. I can't debug how DoubleSpace's minimized/custom Windows 10 is not handling the same mount that works in the Windows 10 installed on the machine using the built-in Windows standard for NTFS folder mounts.

I haven't rebooted the machine yet to allow for debugging into this issue, and have some reservation that a reboot (without the .wim file on the machine) may result in an unbootable machine. I'm not familiar with how .wim files work and their importance.

Should I power cycle the machine at this point?

Re: Reversing DoubleSpace compression

PostPosted: Sun May 10, 2020 3:06 am
by admin
DoubleSpace's "minimized/custom Windows 10" is nothing other than the Windows recovery environment that was already pre-installed on your computer by either your OEM (hardware manufacturer) or Windows itself (if you had manually re/installed Windows 10).

This is often referred to as Windows PE, or Windows RE. If you have your OEM's environment, the benefit is that it would contain all drivers native to your hardware (such as RAID). Yours is the first report where I've heard of it not working properly with anything at all, which in your case ends up being a junction.

Its also a mystery why/how it worked when compressing your disk the first time, versus its failure right now. There's no real difference in the workflow between a first time compression/recompression/uncompression pass.

Unfortunately, there's only so much guessing I can do. If you used a Backup Disk (you couldn't have started the process without it per the above), your data is either unmodified - or safe on the Backup Disk.

I'm not sure why you're thinking the zipmagic.wim file may already be gone at this point. The place you highlighted in the workflow is before that file would be rebuilt...

If you want to be triply safe, you could try to manually copy that file again from your hard disk to an external disk; before cancelling the process.

I can understand how it would all be very scary, and I'll continue doing my best to support you here.

I'm sure you'll go ahead and let me know how it all continues to evolve!